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Introduction 

Clone based import/export functions are enhanced in the Delphi Design Support Library (DSL) to 
support the Delphi Data Creation Standards UG native file naming and iMAN object numbering 
requirements. In addition, using this feature of Unigraphics has several benefits over command line 
scripts based on the ug_import and ug_export utilities. Some of the major ones are: 

• Faster processing since the part files are not actually loaded and saved in UG during the 
process. 

• The interface is part of the Unigraphics menu system, which provides a more user friendly 
Graphic User Interface (GUI) command structure. 

• It’s safer to use with WAVE and other UG technology . 
• Runs on any computer operating system platform that runs Unigraphics. 

This document will present the different types for procedures used to import/export assemblies as 
well as single files using the clone based import/export function. More details about UG/Manager 
clone based import/export can be found in the TeamCenter Engineering (iMAN) online 
documentation, under UG/Manager Help. 

Accessing Create Clone Assembly Online Documentation 

1. Launch UG NX 1 Online Documentation from the Documentation section of the DSL menu.  
This will start the documentation browser. 

Select Documentation -> UG 
NX 1 Online Documentation.

Then click Apply 
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2. Click the Contents tab on the left side of the documentation browser. 
3. Click Other -> UG/Manager -> Using UG/Manager -> UG/Manager Features -> Clone and 

Clone Based Import/Export. 
4. At this point, you can click on the subject you are interested in to access the online 

documentation. 

 

Contents tab 

Start here. 

Documentation 
display window 
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Basic Import Procedure 

The basic import procedure using the clone function is executed from within Unigraphics.  The 
following section provides the steps required to launching TeamCenter Engineering – Motif (iMAN), 
Unigraphics, and the UG/Manager Import Clone Assembly command using the DSL Menu. 

Starting Unigraphics and UG/Manager Import Clone command. 

1. Select TeamCenter Engineering - Motif (iMAN) from the DSL Menu and click Apply.  The 
TeamCenter Engineering workspace will be displayed. 

 NOTE: You can also launch UG by starting UG/Manager.  If you use UG/Manager, 
Unigraphics will start automatically, (Go to STEP 3).  Some sites may have one or the other 
of these commands suppressed in the DSL menu  The following instructions will show 
the steps followed when starting TeamCenter Engineering from the DSL Menu.   

Select TeamCenter 
Engineering, (iMAN). 

Then click Apply 
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2. From the TeamCenter Engineering (iMAN) workspace window, launch Unigraphics by double 
clicking on the UGSTARTUP/00 dataset. 

 

3. From the Unigraphics menu, click Tools->UG/Manager->Import Assembly... or press  on 
the clone toolbar to display the import dialog. 

Import Assembly 
Clone ICON 

 

Double click 
UGSTARTUP 
dataset 
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The Import Clone Assembly Dialog Windows 

Before continuing with the Import Clone Assembly procedure, please review the available options 
on the following Import Assembly dialog windows. 

 
 
 
 
 
 
 
 

 

Allowes you to 
specify one or more 
assemblies to import 

CHECKOUTS TAB: 
Allows you to specify if 
items  are “checked-in”  
or “checked-out” when 
imported. 

NUMBERING TAB:
Permits you to specify if 
the default numbering is 
to be user-defined, a 
number rule or 
automatically generated. 

Enables you to 
select the level of 
report information 
included in the log 
file. 

LOG FILE TAB:
Permits you to 
specify a cloning 
log file to record the 
mapping for the 
cloning operation. 

Permits you to apply 
specific “rules” to 
individual files that will 
be imported. 
 
NOTE: Exceptions 
can be defined on 
many of the “TAB’s” 
sub-menues. 

LOAD OPTIONS TAB: 
Allowes you to specify 
NATIVE UG load 
options for Assembly(s) 
to be imported. 

For Import and Export 
the options available 
here are Overwrite 
(always import the 
part) and Use 
Existing (import the 
part only if it does 
not already exist). 

Enables you to perform the 
operation without actually 
importing (or exporting) the 
objects. 

Executes the 
cloning operation 
based on the 
settings made 
above. 
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NUMBERING TAB: 
Automatically converts 
DCS native file names 
to DCS iMAN object 
numbers. 

Enables you to specify 
the item type for the 
imported object(s). 

 

 

LOG FILES TAB: 
Enables you to load a 
previous cloning log file, 
whose mappings will be 
repeated in your 
operation. 
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OWNERSHIP TAB: 
Used to designate the 
owning user and group 
of the data being imported 
if it is other than the user 
actually performing the 
import operation. 

 

 

Refer to the “INFORMATION window” of the MAIN dialog to keep track of the load options you 
have chosen, the log file you’ve specified (if any), the part numbering method you have selected, 
which assemblies you have chosen for import, etc. 
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Simple Import Assembly Clone Procedure 

1. Click on the Load Options tab and make sure the load options are set as needed for the 
assembly to be able to locate all of its components. 

NOTE: These settings refer to NATIVE UNIGRAPHICS load options, NOT iMAN revision 
rules. 

   

2. Change settings if necessary, then Click on the Main tab. 
3. Press Add Assembly and select the top-level assembly part file to import into iMAN.  Press OK. 

TIP: Repeat this step until all assemblies to be imported have been added to the current 
operation. 

 

NOTE: If you want to import the assembly drawings and the component drawings, use 
Add Assembly to include them in the import. 
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TIP: Check the Add Assembly progress in the Unigraphics STATUS line.  Unigraphics will 
be unresponsive until all the components of the assembly have been resolved. 

 

NOTE: If the components of the assembly can not be located, based on the LOAD 
OPTIONS setting, you will receive the following warning.  Click CANCEL and return to the LOAD 
OPTIONS dialog, (See Step 1), to correct the problem. 
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4. From the Main Import Assembly dialog, select Use Existing from the Default Import Action 
drop down list.  Use this option if the assembly was initially exported from the iMAN database, or 
some components of a new assembly already exist in the iMAN database. 

 

5. Click on the Numbering tab and select Auto Translate  from the Import Numbering drop 
down list. 

 

NOTE: In order for AUTO TRANSLATE to function properly, STRICT adherence to the 
Delphi Data Creation Standard file naming conventions for NATIVE UG files is REQUIRED. 
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6. Click the Checkouts tab and select the Check-In button if you want the files to automatically be 
checked-in on import. 

 

7. Click the Main tab and check Dry Run and press Execute to see if there will be any possible 
problems with the import.  

 

TIP: Check the Import Assembly progress in the Unigraphics STATUS line.  Unigraphics 
will be unresponsive until all the components of the assembly have been resolved. 
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NOTE: The results of clicking Dry Run and then Execute will be displayed in the 
Unigraphics Information window.  Following is an example of the output you might expect to see.   
Click File -> Close to close the information window. 

 

Default settings for 
import clone operation. 

Settings for file 
11111110.mldes.0000.prt. 
Note the file name conversion 
to iMAN conventions, part type, 
etc. 
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8. Select Full from the Reports drop down list then click Report to Information Window to verify 
that all parts will be numbered correctly.  

 

NOTE: The results of selecting Full from the Reports drop down list and clicking Reports 
to Information Window will be displayed in the Unigraphics Information window.  Following is 
an example of the output you might expect to see.  Click File -> Close to close the information 
window. 
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9. If any numbers or part types are incorrect, or you want to change the Part Name and/or Part 
Description, press the Numbering tab then Import Numbering Exceptions to correct the 
number or Default Part Type to correct the part type of the problem part.  If everything is OK, 
skip to step 13. 

 

10. Select the file for which you would like to define the numbering exception and click APPLY.  This 
will cause the iMAN file dialog window to appear. 

NOTE: When defining a part type exception, select the file, then select the part type from the 
drop down list and then click apply.  When finished, click Cancel. 
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11. Correct the Part Number and Part Revision to be what you desire, in accordance with Delphi 
iMAN DCS object numbering rules. 

 Correct Part Number 
and Revision Number. 
 
Click OK to continue. 

 

12. Click OK to proceed to the next screen where you can correct the Part Name and Part 
Description. 

       

Select Part Name and 
enter a new VALUE. 
Push ENTER on the 
key’bd. to Proceed. 

Select Part Description 
and enter a new 
VALUE.  Click OK to 
Proceed. 
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13. Once you are satisfied that all files can be resolved and numbering exceptions are defined, 
make sure Dry Run is turned off and press Execute from the Main tab of the dialog window to 
import the files.  

 

TIP: Check the Import Assembly progress in the Unigraphics STATUS line.  Unigraphics 
will be unresponsive until all the components of the assembly have been imported. 
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NOTE: The results of the import operation will be displayed in the Unigraphics Information 
window.  Following is an example of the output you might expect to see.  Click File -> Close to 
close the information window. 
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Importing UG Scenario Files 

To import an assembly with UG/Scenario files requires a slightly different procedure.  Steps 3 and 5  
are different and are highlighted in red: 

1. Launch TeamCenter Engineering – Motif (iMAN) from the DSL Menu and start Unigraphics by 
double clicking the UGSTARTUP dataset from the TeamCenter Engineering (iMAN) workspace.  
If you click UG/Manager, Unigraphics will start automatically, (Go to STEP 3).   (Refer to 
Starting Unigraphics and UG/Manager Import Clone command in the previous section for 
details.) 

NOTE: Some sites may have one or the other of these commands suppressed in the 
DSL menu  The following instructions will show the steps to be followed when starting 
TeamCenter Engineering – Motif (iMAN) from the DSL Menu.   

2. From the Unigraphics menu, click Tools->UG/Manager->Import Assembly... or press  on 
the clone toolbar to display the import dialog. 

NOTE: Refer to the steps in the “Simple Import Assembly Clone Process” section for 
additional information on the following steps. 

3. Select the Load Options tab and make sure the load options are set as needed to find 
assembly components and to allow the scenario files to find the associated part. 

4. Press Add Assembly and select the top-level assembly part file to import into iMAN and press 
OK.  

5. Use Add Assembly to include all of the scenario files in the import operation. 
6. Click the Main tab and select Use Existing  from the Default Import Action drop down list. 
7. Click the Numbering tab and select Auto Translate from the import Numbering drop down list. 
8. Click the Checkouts tab and select Checked In if you want the files to automatically be 

checked in on import. 
9. Click the Main  tab and select Dry Run.  Press Execute to see if there will be any possible 

problems with the import.  
10. Select Full from the Reports drop down list then click Report to Information Window to verify 

that all parts will be named correctly. If any names are incorrect, click Exceptions under the 
Numbering tab to correct the number of the problem part.  

11. Once satisfied, make sure Dry Run is turned off and press Execute to import the files.  

NOTE: All UG/Scenario part files MUST have scenario in the name for the auto translate to 
recognize it as a UG/Scenario part file. 
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Basic Export Procedure 

The Export Clone Assembly Dialog Windows 

The Export Clone Assembly dialog windows are similar to the Import dialogs.  Before continuing 
with the Export Clone Assembly procedure, please observe some of the differences on the following 
Export Assembly dialog window. 

 
 
 
 
 

 

CHECKOUTS TAB: 
Allows you to specify if 
items  are “checked-out” 
when exported. 

NAMING TAB:
Specifies whether 
you want the default 
NATIVE UG part file 
naming to be user-
defined, a file naming 
rule or automatically 
generated. 

LOAD OPTIONS TAB: 
Allowes you to specify 
IMAN Revision Rule 
to use for the 
Assembly(s) to be 
exported. 

In general there are fewer 
EXPORT option tabs. 
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Simple Export Assembly Clone Procedure 

1. Click on the Load Options tab and make sure the iMAN revision rules are set as needed for the 
assembly to be able to locate the all its components. 

NOTE: These settings refer to iMAN REVISION RULE settings, NOT Native UG load 
options. 

   

2. Change settings if necessary, then Click on the Main tab. 
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3. Press Add Assembly and select the top-level assembly item revision to export out of the iMAN 
database and press OK.  

  

TIP: Repeat this step until all assemblies to be exported have been added to the current 
operation. 

NOTE: If you want to export the assembly drawings and component drawings that are 
the UGMASTER dataset(s) of a Drawing_DPH object, use Add Assembly to include them in 
the import operation. 

TIP: Check the Add Assembly progress in the Unigraphics STATUS line.  Unigraphics will 
be unresponsive until all the components of the assembly have been resolved. 
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NOTE: If the components of the assembly can not be loaded, based on the REVISION 
RULE setting, you will receive the following warning.  Click CANCEL and return to the LOAD 
OPTIONS dialog, (See Step 1), to correct the problem. 

 

4. From the Main Export Assembly dialog, select Use Existing from the Default Export Action 
drop down list.  Use this option if the assembly has been previously exported from the iMAN 
database, or some components of a new assembly already exist in the native UG output 
directory. 
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5. Click on the Naming tab and select Auto Translate  from the Export Naming drop down list. 

 

NOTE: In order for AUTO TRANSLATE to function properly, STRICT adherence to the 
Delphi iMAN Data Creation Standard file naming conventions is REQUIRED. 

6. Click the Checkouts tab and select the Check-Out button if you want the items to automatically 
be checked out on export. 
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7. Click the Main tab and check Dry Run and press Execute to see if there will be any possible 
problems with the export. 

 

TIP: Check the Add Assembly progress in the Unigraphics STATUS line.  Unigraphics will 
be unresponsive until all the components of the assembly have been resolved. 
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NOTE: The results of clicking Dry Run and then Execute will be displayed in the Unigraphics 
Information window.  Following is an example of the output you might expect to see.   Click File -> 
Close to close the information window. 

Default settings for 
export clone operation. 

Settings for item revision 
TCTASM02/00. 
Note the item revision 
name conversion to 
NATIVE UG file name 

ti
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8. Select Full from the Reports drop down list then click Report to Information Window to verify 
that all parts will be named correctly.  

  

NOTE: The results of selecting Full from the Reports drop down list and clicking Reports 
to Information Window will be displayed in the Unigraphics Information window.  Following is 
an example of the output you might expect to see.  Click File -> Close to close the information 
window. 
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9. If any names are incorrect, or you want to change the file name, press Naming tab then 
Exceptions to correct the name of the problem item revision.  If everything is OK, skip to step 
13. 

  

10. Select the item revision you would like to define the naming exception for and click APPLY.  This 
will cause the native UG file dialog window to appear 
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11. Correct the native UG file name to be what you desire, in accordance with Delphi DCS Native 
UG file naming rules. 

 

Enter File Name.
 
Click OK to continue. 

 

12. Click OK to return to the Naming Exceptions dialog. Repeat step 10 and 11 until you have 
defined all the naming exceptions you desire.  When finished, click CANCEL to dismiss the 
dialog window. 
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13. Once you are satisfied that all item revisions load and any exceptions you want to make are 
defined, make sure Dry Run is turned off and press Execute from the Main tab of the dialog 
window to export the iMAN objects. 

 

TIP: Check the Export Assembly progress in the Unigraphics STATUS line.  Unigraphics 
will be unresponsive until all the components of the assembly have been exported. 
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NOTE: The results of the export operation will be displayed in the Unigraphics Information 
window.  Following is an example of the output you might expect to see.  Click File -> Close to 
close the information window. 
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Exporting UG Scenario Files 

Exporting UG/Scenario files does not require any additional steps then the normal export procedure. 
Make sure that the scenario relation is selected under Non-Master/Associated File Export tab. 

Clone Import/Export Command-Line Utility 

EDS/PLM (Unigraphics) provides a command-line utility that “duplicates” most of Import/Export 
Clone functions available in the UG/Manager Import/Export Assembly dialogs.  It is recommended 
that you NOT use the command-line utility if you have access to TeamCenter Engineering 
and UG. 

To use the command-line utility, open a DSL Terminal window from the DSL Menu. 

 
 

 

Select DSL Terminal 
from the Tools menu 
and click APPLY 

A terminal window 
should appear.  Use 
this window to run the 
UG-Clone command-
line utility 
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In the terminal window, execute ug_clone. The program takes the following arguments: 

KEYWORD VALUE 

-p [pim] Set to yes to initialize UG/Manager, rather than native Unigraphics NX. 

-u [user] iMAN username. 

-g [group] iMAN group. 

-p [password] iMAN password. 

-o [operation] These keyword values are required: clone, edit, import, export. These 
keyword values must precede the following arguments. 

-asse [assembly] Specifies the root assembly. To add an assembly to the operation, the 
value may be repeated. 

-p [single part] Specifies the Item ID of a single part of the assembly to 
be cloned. To add a part to the assembly, this value may 
be repeated. 

-default_checki [default check-in] The default setting is no. 

-default_checko [default check-out] The default setting is no. yes:<comment>|no. 

-default_a [default action] The values are clone, retain, overwrite, use_existing. 

default_n [default naming] The values are autogen, autotranslate, name_rule, user_name. 

-default_t [default type] Specifies the default UG/Manager item type. 

-asso [associated file root directory] Specifies the default UG/Manager associated file 
directory. 

-copy_a [copy associated files] Specifies whether to copy UG/Manager Associated files. The default 
setting is yes. 

-copy_n [copy non-master] Specifies whether to copy UG/Manager Non-Master files. This value may 
be repeated. 

-default_o [default owner]=<user><group> Specifies the default UG/Manager user and group to own the parts. 

-n [name rule] The keyword values are: prepend, append, replace, rename. 
prepend:<string> 
append:<string> 
replace:<base_string> 

-l [load log file]=<log_file_name> This value may be repeated. 

-s [save log file]=<log_file_name> The default setting is <operation>.clone. 

-dryrun Indicates whether the utility will proceed as expected, 
without actually performing the clone. 

 
Refer to the UG NX 1 Online Documentation for more information. 
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Batch Clone Import Example 

In the Terminal windows, type the following commands: 

1. cd <directory where files to import are>  
2. ug_clone -pim=yes -o=import -default_a=overwrite -

default_n=autotranslate -asse=12345678.mlasm.0004.prt -
asse=87654321.mlasm.0002.prt  

Batch Clone Export Example 

In the Terminal windows, type the following commands: 

1. cd <directory to place exported files in>  
2. ug_clone -pim=yes -o=export -default_a=overwrite -

default_n=autotranslate -asse=@DB/12345678/02  

NOTE: To export an Item/Rev from the database it MUST be written in the form: 
@DB/<item name>/<rev> 

Batch Clone Using A Clone Log File 

Sometimes more control is needed that cannot be specified easily in ug_clone. The way to utilize all 
the functionality and also use ug_clone is to create clone log files. To do this follow these steps: 

1. Follow the appropriate steps to import or export the assemblies using the UG/Manager 
Import/Export Assembly Clone dialog. Stop before executing the dry run(step 7).  

2. Press the Specify button under the Log Files section.  
3. Enter the log file name and press OK.  
4. Toggle on Dry Run and press Execute. The log file will be created at this point.  
5. Exit UG/Manager and open a Terminal window using the DSL Menu.  
6. Type in the command: 

ug_clone -pim=yes –o=<import/export> -l=<log filename>.  

This process can be useful for importing at a remote site. Create the clone log file locally, transfer 
the files and the log file to the remote site and then run ug_clone at the remote site.  


